苹果再次提醒:4月起强制要求APP进行适配 - 热点资讯

软件适配对于许多厂商来说都是一个比较头疼的事,苹果在握紧 AppStore 审核权的情况下情况要好许多。

最近他们公布了两条新的要求:4 月起 iOS 软件必须适配 iOS 13 和 iPhone XS Max,4 月 30 日期 iPad 软件也必须适配所有型号的 iPad 产品。

其中,苹果要求所有新 APP 和更新都是用 iOS 13 SDK 来构建,并且需要支持 iPhone XS Max 以及更新产品的全面屏设计。

iPhone XS Max 和 iPhone 11 Pro Max 由于使用了更大的屏幕以及分辨率,目前仍然有部分软件无法正常全屏显示,不过苹果并没有强制要求必须适配 iOS 13 的深色模式。

苹果还要求新版本应用程序使用 Xcode storyboards 和自动版式等功能,从而在 iPhone 和 iPad 等不同产品当中提供自适应显示,watchOS 软件也必须支持 watchOS 6 以及 Apple Watch Series 4 以及更新版本。

iPad 应用方面,苹果要求新版应用能够适配所有 iPad 屏幕的大小和宽高比,界面的元素和办事可以自动适应显示要求。同时强烈建议支持多任务、多窗口和「画中画」等功能。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

留言与评论(共有 条评论)
   
验证码: